Escort Radar Forum  

Go Back   Escort Radar Forum > Escort Live! > Escort Live! for Android

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old October 30th, 2015
baddad63 baddad63 is offline
Junior Member
 
Join Date: Oct 2015
Posts: 2
Default Unfortunately escort live has stopped working

Escort live worked fine for about a week and now every time I try to launch the app on my Galaxy S4 I get this message "Unfortunately escort live has stopped working". Anyone else have this problem?
Reply With Quote
  #2  
Old October 30th, 2015
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,996
Default

I have heard of a couple instances of this happening. We are looking into it.

What most probably happened is that you have Google Play set to auto update your apps without approval. It updated Escort Live to v2.1.4 which is now not operating on your phone. It seems that some phones will not run the latest version. We are looking into why and hope to have another update available soon to solve this.

In the meantime if you would like to install the previous version then you will need to:
1) Disable Google Play's auto update feature which is found in the Google Play app's settings.

2) Uninstall Escort Live.

3) Download the older Escort Live v213 APK file to your phone. It is an 11MB file so you may want to use a wifi connection when downloading it. Here is a link to the APK file, clicking it should start the download.

4) Once downloaded the APK file will be in your "Downloads". Here is a Google search of APK installation tutorials, it is very simple to do.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or you can fill out a repair form and we will contact you.

Last edited by EscortRadar; October 30th, 2015 at 01:25 PM.
Reply With Quote
  #3  
Old November 19th, 2015
baddad63 baddad63 is offline
Junior Member
 
Join Date: Oct 2015
Posts: 2
Default

Thanks that worked.
Reply With Quote
  #4  
Old November 19th, 2015
Ducman69 Ducman69 is offline
Junior Member
 
Join Date: Nov 2015
Posts: 4
Default

Quote:
Originally Posted by EscortRadar View Post
I have heard of a couple instances of this happening. We are looking into it.

What most probably happened is that you have Google Play set to auto update your apps without approval. It updated Escort Live to v2.1.4 which is now not operating on your phone. It seems that some phones will not run the latest version. We are looking into why and hope to have another update available soon to solve this.

In the meantime if you would like to install the previous version then you will need to:
1) Disable Google Play's auto update feature which is found in the Google Play app's settings.

2) Uninstall Escort Live.

3) Download the older Escort Live v213 APK file to your phone. It is an 11MB file so you may want to use a wifi connection when downloading it. Here is a link to the APK file, clicking it should start the download.

4) Once downloaded the APK file will be in your "Downloads". Here is a Google search of APK installation tutorials, it is very simple to do.
Can you inform your tech support of this issue? It was a specific question of mine, yet I was asked to do all kinds of troubleshooting and ultimately got authorization to send my SmartRadar in for warranty repair (at my shipping expense) when finally I did some more research and found that everything works fine on a Galaxy S4 (4.4.4) and Galaxy S6 (5.1.1) with the old version 2.1.3 when it would not connect with 2.1.4.

The two technicians I talked to had no idea about this bug, and I would have been quite perturbed if I got the radar detector back and it still wasn't working.
Reply With Quote
  #5  
Old November 29th, 2015
SaltiDawg SaltiDawg is offline
Senior Member
 
Join Date: Oct 2015
Posts: 165
Default

Quote:
Originally Posted by EscortRadar View Post
...
In the meantime if you would like to install the previous version then you will need to: ...
Thanks. I just did this on my phone and I no longer have the non-display of PSL on the MAX 360.

I'm not sure what feature(s) I may have lost by going back, but it seems to be a good work around.
Reply With Quote
  #6  
Old December 1st, 2015
SaltiDawg SaltiDawg is offline
Senior Member
 
Join Date: Oct 2015
Posts: 165
Default

So, I've put a couple of hours on the previous version of EL.

Four Changes:

a) The PSL appears on the MAX 360 display 100% of the time - even after starting up EL, shutting down, etc. If no PSL in data base, I get the expected two dashes.

b) If I come to a stop and there is a known PSL, it is now displayed. With the new update, I was getting just dashes.

c) With the previous version, EL has crashed twice on startup.. it asks me if I wanted to report it.

d) The RD pairs without issue with EL when both are turned on - no prompting required.

An unanticipated benefit is my blood pressure has come down.

Last edited by SaltiDawg; December 1st, 2015 at 09:03 PM.
Reply With Quote
  #7  
Old February 22nd, 2016
UtilityBelt70mph UtilityBelt70mph is offline
Member
 
Join Date: Mar 2015
Posts: 79
Default no lie it happens 3 times within 10 minutes

Quote:
Originally Posted by baddad63 View Post
Escort live worked fine for about a week and now every time I try to launch the app on my Galaxy S4 I get this message "Unfortunately escort live has stopped working". Anyone else have this problem?
and my max never reconnects when i reopen the app, so i have to unplug the unit and reboot it too. only for the app to crash 3 minutes later. by that time i give up. I get KA alerts on my max, but unfortunately, they don't get uploaded to EL, cause the app is so unstable. i can't keep fiddling around with my phone while i'm on an interstate.
__________________
Galaxy S7 Edge
Escort Live 2.1.7
Android 6.0.1
AT&T
PassPort Max1
Dual SmartCord Live
Reply With Quote
  #8  
Old February 23rd, 2016
Zak Zak is offline
Banned
 
Join Date: Jan 2016
Posts: 311
Default

Quote:
Originally Posted by UtilityBelt70mph View Post
and my max never reconnects when i reopen the app, so i have to unplug the unit and reboot it too. only for the app to crash 3 minutes later. by that time i give up. I get KA alerts on my max, but unfortunately, they don't get uploaded to EL, cause the app is so unstable. i can't keep fiddling around with my phone while i'm on an interstate.
This has been happening for over a month for me but EL is not that useful anymore so I don't complain.
It takes 2-3 attempts to get the app to communicate with my Max2. It does this every time. Escort suggested I back out of the app as opposed to other methods of closing but always do that anyway.

I don't have the time, nor desire, to spend playing with, reloading, deleting, and updating an app that's suppose to make my life easier.
Reply With Quote
  #9  
Old February 23rd, 2016
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,996
Default

Quote:
Originally Posted by UtilityBelt70mph View Post
and my max never reconnects when i reopen the app, so i have to unplug the unit and reboot it too. only for the app to crash 3 minutes later. by that time i give up. I get KA alerts on my max, but unfortunately, they don't get uploaded to EL, cause the app is so unstable. i can't keep fiddling around with my phone while i'm on an interstate.
I don't know what to tell you UtilityBelt70mph. I use the same phone as you except on Verizon and Escort Live runs great on it for hours at a time. See the attached picture of my phone's specifications. If you are sending the crash reports they will help us.

Make sure that you are exiting the app by using the back button on the bottom right of your phone then selecting OK. Don't use the left bottom button then swipe close Escort Live or you will continue to have issues with it auto-connecting.
Attached Images
 
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or you can fill out a repair form and we will contact you.
Reply With Quote
  #10  
Old December 23rd, 2017
RKZZD RKZZD is offline
Junior Member
 
Join Date: Aug 2016
Location: WA State
Posts: 28
Default

I feel the pain. I have sent the crash data several times from my Samsung S7 Edge on Verizon recently.

For the record: I drive 3+ hours a day to and from work. I turn on Escort Live as I leave home/work and have to restart the app a few times each day.
__________________
Passport Max2 in my jeep
Passport 9500iX in wife's kia
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.