Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360c

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old March 20th, 2020
TonyRI's Avatar
TonyRI TonyRI is offline
Senior Member
 
Join Date: Oct 2015
Location: Rhode Island
Posts: 338
Default

Wow, I would have expected a much shorter time period, but that's well over a year. Maybe it just happens once in awhile? I agree, it would be interesting to get more information about loose antenna casting screws. How prevalent it is, can users fix it themselves, etc.

Well anyway, I just finished registering, updating Defender Database, setting up EL and WiFi and ready to take it for a spin.

Thanks for your good wishes!
Reply With Quote
  #22  
Old March 21st, 2020
adaboy4z adaboy4z is offline
Junior Member
 
Join Date: Mar 2018
Location: West Texas
Posts: 1
Default

my 360c will do that about once a week when I first turn on the car. I unplug the detector and it seem to solve the issue. Its a constant slow 2 beeps every 3 or 4 seconds.
Reply With Quote
  #23  
Old March 21st, 2020
TonyRI's Avatar
TonyRI TonyRI is offline
Senior Member
 
Join Date: Oct 2015
Location: Rhode Island
Posts: 338
Default

It falses on Ka band? Do you know the mfg date code (last 4 digits after S/N)?

I went through the unplugging and plugging in, re-flashing firmware, resetting to factory default, checked to see if my phone was interfering, etc., and it was a manufacturing issue (solder/screws).

I've taken the 3rd replacement unit out a couple of days now and it is working perfectly (finally, yay!).

I've owned radar detectors since Cincinnatti Microwave. I also had the passport, the 8500, the 9500ix, the 360 and the 360c. I knew that my original purchase and the previous replacements weren't operating correctly. It was driving me nutty.

It was so nice to drive 2 days without any false Ka signals. The other units falsed within a day after they were unboxed and installed.

Last edited by TonyRI; March 22nd, 2020 at 07:43 AM.
Reply With Quote
  #24  
Old March 27th, 2020
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 672
Default

Sounds like a issue that'll have to be repaired at Escort Repair Department. Call to set up a repair.
__________________
I use the following Escort Products

Escort Redline EX
Max360c with wifi
M1 Dash cam with both detectors
Escort Live
ZR5 Shifters
------------------------------------------------------------
Reply With Quote
  #25  
Old April 5th, 2020
Kruppa Kruppa is offline
Junior Member
 
Join Date: Mar 2020
Posts: 18
Default

Quote:
Originally Posted by Esc0rtFan View Post
Sounds like a issue that'll have to be repaired at Escort Repair Department. Call to set up a repair.
Mine is doing this about 50% of the time since I got the detector (very new, just got about a week ago). When I start up the car in the morning I'll get a K band alert or KA band alert and it will not stop even when I start driving unless I power cycle the unit. This morning it was alternating between saying there was 1 and 4 signals. So annoying. So I guess I have to just wait until they are up and running again and then go without a detector for a while while they solder or fix whatever?
Reply With Quote
  #26  
Old April 5th, 2020
Butcher318 Butcher318 is offline
Armchair Expert
 
Join Date: Dec 2011
Location: Indiana
Posts: 2,083
Default

Quote:
Originally Posted by Kruppa View Post
Mine is doing this about 50% of the time since I got the detector (very new, just got about a week ago). When I start up the car in the morning I'll get a K band alert or KA band alert and it will not stop even when I start driving unless I power cycle the unit. This morning it was alternating between saying there was 1 and 4 signals. So annoying. So I guess I have to just wait until they are up and running again and then go without a detector for a while while they solder or fix whatever?
If your still in your 30 trial period I would just return it for a new one.
Reply With Quote
  #27  
Old April 5th, 2020
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 672
Default

It shouldn’t do this for sure. Time to
Switch it out
__________________
I use the following Escort Products

Escort Redline EX
Max360c with wifi
M1 Dash cam with both detectors
Escort Live
ZR5 Shifters
------------------------------------------------------------
Reply With Quote
  #28  
Old April 5th, 2020
Kruppa Kruppa is offline
Junior Member
 
Join Date: Mar 2020
Posts: 18
Default

Quote:
Originally Posted by Esc0rtFan View Post
It shouldn’t do this for sure. Time to
Switch it out
Their site says they aren’t accepting returns or repairs so do I just have to pay another $600 and they’ll refund me for the first one whenever this all ends?
Reply With Quote
  #29  
Old April 5th, 2020
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 672
Default

Quote:
Originally Posted by Kruppa View Post
Their site says they aren’t accepting returns or repairs so do I just have to pay another $600 and they’ll refund me for the first one whenever this all ends?
No I don’t think they’d do that unfortunately.
__________________
I use the following Escort Products

Escort Redline EX
Max360c with wifi
M1 Dash cam with both detectors
Escort Live
ZR5 Shifters
------------------------------------------------------------
Reply With Quote
  #30  
Old April 5th, 2020
Kruppa Kruppa is offline
Junior Member
 
Join Date: Mar 2020
Posts: 18
Default

Quote:
Originally Posted by Esc0rtFan View Post
No I don’t think they’d do that unfortunately.
Do you mean they’ll ask me to send it in for repair? The easier thing would be to return the current one (within 30 days) and buy new one right?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:42 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.