Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360c

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old May 30th, 2019
renegade54 renegade54 is offline
Junior Member
 
Join Date: May 2019
Posts: 7
Default Max360c not showing PSL

Hi, On my app it shows what the PSL is but not on my max360c. Any suggestions?
Attached Images
 
Reply With Quote
  #2  
Old May 31st, 2019
Tingtang Tingtang is offline
Member
 
Join Date: May 2019
Posts: 36
Default

im having same issue, seems like there's really only a handful of people on this forum that can help. at least from the responses I've been reading. seems the only active people are people with questions and need help, lol. but ill let you know when I figure it out.
Reply With Quote
  #3  
Old May 31st, 2019
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 411
Default

Quote:
Originally Posted by Tingtang View Post
im having same issue, seems like there's really only a handful of people on this forum that can help. at least from the responses I've been reading. seems the only active people are people with questions and need help, lol. but ill let you know when I figure it out.
I am trying to help. I may not know it all but I'll do my best.

Now on another thread I just read that someone may have been able to disable Bluetooth on their 360c while using wifi and the speedlimit then appeared?

Try that.
__________________
I use the following Escort Products

Escort Redline EX
Max360c with wifi
M1 Dash cam with both detectors
Escort Live
ZR5 Shifters
------------------------------------------------------------
Reply With Quote
  #4  
Old May 31st, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,864
Default

We are looking into why some are reporting not receiving speed limits over Wi-Fi. So far we have not been able to reproduce it, even after replacing their units. This tells me that the issue is then either:

1) You were not logged into your premium Live account when you connected it to Wi-Fi. You can check this in Escort Live's "Subscriptions" screen. It should show a future date. If it does, bluetooth connect to the detector again and it will transfer these credentials to the detector.
-or-
2) Your Wi-fi hotspot does not have internet connectivity.
3) Poor GPS. Your detector is not getting a good GPS signal. This can be verified by the current speed indicator. It should show 0 when stopped. If anything else, it has poor GPS. The GPS chip is located in the top of the unit so if you have metallic object blocking its view of the sky, that could be causing the issue. Try temporarily mounting it elsewhere and check speed limits.

Tingting,
You previously said you updated the MAX 360c via Wi-Fi, this means your Wi-Fi hotspot has an internet connection. Only check 1 and 3
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat

Last edited by EscortRadar; May 31st, 2019 at 03:54 PM.
Reply With Quote
  #5  
Old June 1st, 2019
Litespeed1000 Litespeed1000 is offline
Junior Member
 
Join Date: Jun 2019
Posts: 1
Default

I had this issue until I changed my app password and made sure my vpn norton and add blocker are turned off. So far so good for me.
Reply With Quote
  #6  
Old June 1st, 2019
ToddAHoyle ToddAHoyle is offline
Junior Member
 
Join Date: May 2019
Posts: 12
Default

I posted last week that I could not get PSL on wifi either. I could on blue tooth. I tried everything I read to get it to work. still no go. I had read that special characters in the password could cause this. I changed my password. Factory reset the detector. Reconnected everything and still no go. On Monday I get an update over wifi, and since then I no longer get psl even in blue tooth. I just get the blue tooth symbol. The escort live app shows the correct speed. The radar detector indicates when I go over the speed limit, but it just won't show psl at all now. Blue tooth or wifi. Any suggestions welcome.
Reply With Quote
  #7  
Old June 2nd, 2019
ToddAHoyle ToddAHoyle is offline
Junior Member
 
Join Date: May 2019
Posts: 12
Default

UPDATE - I turned off display speed and turned it back on and now I get speed limit when connected to bluetooth again. Still no speed limit display on wifi though.
Reply With Quote
  #8  
Old June 3rd, 2019
Tingtang Tingtang is offline
Member
 
Join Date: May 2019
Posts: 36
Default

Quote:
Originally Posted by Litespeed1000 View Post
I had this issue until I changed my app password and made sure my vpn norton and add blocker are turned off. So far so good for me.
How did you change app password?
Reply With Quote
  #9  
Old June 3rd, 2019
Tingtang Tingtang is offline
Member
 
Join Date: May 2019
Posts: 36
Default

Quote:
Originally Posted by ToddAHoyle View Post
I posted last week that I could not get PSL on wifi either. I could on blue tooth. I tried everything I read to get it to work. still no go. I had read that special characters in the password could cause this. I changed my password. Factory reset the detector. Reconnected everything and still no go. On Monday I get an update over wifi, and since then I no longer get psl even in blue tooth. I just get the blue tooth symbol. The escort live app shows the correct speed. The radar detector indicates when I go over the speed limit, but it just won't show psl at all now. Blue tooth or wifi. Any suggestions welcome.
Mine is the same. You get the over speed limit alert even when PSL is white with 2 dashes because your phone and escort live are also connected through BT still. The detector piggybacks the app when its running, whether open or in background. So you get the alert when you go 10 over speed limit, or whatever you set that to. If you turned BT off on detector you wouldn't get the over speed alerts for speed limit, but instead u get it for whatever speed you set it for, like 70mph over speed. Not sure if I made any sense
Reply With Quote
  #10  
Old June 3rd, 2019
ToddAHoyle ToddAHoyle is offline
Junior Member
 
Join Date: May 2019
Posts: 12
Default

Quote:
Originally Posted by Tingtang View Post
How did you change app password?
https://www.escortradar.com/pages/update-live-password
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:44 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.