View Single Post
  #24  
Old February 14th, 2019
crmgr crmgr is offline
Member
 
Join Date: Aug 2013
Location: Brunswick Hills, Ohio
Posts: 66
Default

Originally KA segmented 2,5,6,8 active. Then enabled all bands. No change. Also tried doing a reset, since another post said CS at Escort told him that was a fix. No change. Frustrating. Would have been nice to get an error message.


Quote:
Originally Posted by EscortRadar View Post
It sounds like you might have Ka band, or parts of Ka band, disabled. Reset your EX to factory defaults and try it. To do this, hold down MARK and BRT buttons while turning on the unit until you see the "factory settings restored" message, then release the buttons.
Reply With Quote