View Single Post
  #5  
Old March 17th, 2017
Butcher318 Butcher318 is offline
Senior Member
 
Join Date: Dec 2011
Location: Indiana
Posts: 1,856
Default

Quote:
Originally Posted by HughH View Post
Over the years, I've need to re-calibrate the screen on my iQ since the point of impact would change from the point of aim over a short time.

This time, the "Settings" button refuses to engage. Clicking anywhere on "Settings" causes large "Go To" button underneath it to be activated. I am pressing the screen with the tip of a 5.56 round so the area of impact is tiny. Even I tap the very top of the "Settings" button, the "Go To" engages. Clicking within the thin area of touch screen between the top of the "Settings" button and the screen bezel accomplishes nothing.

I tried multiple hardware resets with the good old paperclip but I am stumped!

Does anyone have any ideas or does sound like an issue that's going to need the iQ to take a little trip to Ohio?

P.S. Dear Escort Radar Customer Service forum rep, please tell your IT guys to please renew the SSL certificate for info.notice.escortradar.com
My security software is screaming at me when I visit the main website to look at new detectors.
I hope you can get it working since this unit has been discontinued. There is also no longer any support or updates for it and I don't think Escort will even service or repair one. You will have to call and check and see if they do still repair them.

Last edited by Butcher318; March 17th, 2017 at 12:09 AM.