Escort Radar Forum

Escort Radar Forum (http://escortradarforum.com/forums/index.php)
-   Escort Live! for Android (http://escortradarforum.com/forums/forumdisplay.php?f=47)
-   -   X80 bluetooth issue, Android (http://escortradarforum.com/forums/showthread.php?t=17719)

g094389 June 11th, 2018 12:27 PM

X80 bluetooth issue, Android
 
I have a brand new android phone made by Razer. It is a flagship phone, well respected in the Android community. It is running unmodified, stock Android 8.1.

My Escort X80 was professionally installed on Sat and appears to be functional in most regards. I followed the owners manual to register the serial number, I have confirmed that this process is complete. I also followed the owners manual instructions to connect my phone to the RD via bluetooth. The BT logo displays on the face of the RD and it is listed in the BT configuration settings page of the Android Settings interface. However, once I start the Escort Live app which I downloaded from the approved playstore, the app does not recognize that the bluetooth connection exists and my phone is not listed when I select the red bluetooth icon in the upper right corner of the app.

I'm a systems engineer and a gearhead so I find it unusual that the process was completed without error in every respect but that the app still does not list the RD. I read a similar thread below on this forum but that was focused on an IOS 11 issue and was not related other than it had bluetooth in the title.

If an employee of Escort is not available to address this issue, is there someone else that can provide any guidance regarding this issue? Thanks in advance.

flylow7f39 June 11th, 2018 08:37 PM

Have you tried un-pairing and re-pairing?

Quote:

Originally Posted by EscortRadar (Post 143189)
I doubt if there is an issue with your detector. If there was then it would never connect. Try un-pairing and re-pairing your MAX 360c. This can solve bluetooth connection issues.

Due to app resource restrictions while backgrounded that were introduced in Android 8, Escort Live's functionality while it is in the background has been limited. Hopefully we can work around these issues.

Our devices auto-connect excellently on iPhone. This is not due to a limitation with the Escort Live app or the bluetooth implementation that we use in our devices.


g094389 June 11th, 2018 08:51 PM

I have made multiple attempts to reset, reconfigure, and some additional troubleshooting steps. I work with android and iOS both professionally and specialize in mobile device management. Suffice to say that I'm pretty well past layperson level troubleshooting steps and am going to see if I can grep the logs from my phone and the Rd this evening.

There is a problem. It is possible but not probable that the issue is with the phone. I'll get back to you once I have a chance to parse the logs.

EscortRadar June 13th, 2018 01:27 PM

There are known BLE connection issues with Escort Live and Android 8.x. We have an app update coming soon which should resolve these bluetooth connection issues.

The fix will be Escort Live handling bluetooth pairing for Escort devices. After the app update you will pair the detector through Escort Live, not Android.


All times are GMT -4. The time now is 01:27 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.